Recherche développeur php/phpbb pour mettre à jour la balise Dice

Si vous souhaitez traduire, relire, écrire... Bref participer, c'est par ici
Règles du forum
Vous ne pouvez plus créer de sujet dans ce forum. Si vous souhaitez contribuer au DDD de quelque manière que ce soit, veuillez lire ce topic pour connaître la marche à suivre.
Avatar de l’utilisateur
szass
Staff - Façonneur de Donjons
Messages : 10170
Inscription : Jeu 29 Mars 2012 15:28
Localisation : Oubliettes du Donjon
Version de D&D préférée : AD&D2
Univers de D&D préféré : Planescape
Race : Githyanki
Classe : Illusionniste
Alignement : Chaotique Neutre
Dieu : Vlaakith CLVII
Mini Feuille de perso :

Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar szass » Dim 12 Avr 2020 17:14

Bonjour,
Comme l'indique le titre, je cherche un développeur qui connaît à la fois php et le CMS phpbb (version 3.2.9 ou 3.3.0), pour mettre à jour l'extension Fancy Dice BBcode (de hanelyp), qui n'est plus maintenue depuis longtemps, afin qu'elle soit compatible avec phpbb 3.2.9 ou 3.3.0 donc.
Actuellement, nous sommes en phpbb 3.1.12 (la dernière version stable de la branche 3.1.x).
Et si possible que les dés déjà lancés avec la version actuelle s'affichent toujours correctement une fois la nouvelle version installée. :)

Ce genre de boulot est hors de mes compétences, et sans la MAJ de cette extension, je ne peux pas mettre à jour le forum, sinon vous ne pourrez plus lancer de dés. :?

Un grand merci à celui ou celle qui se penchera dessus. :)
Lolth tlu malla. Jal ultrinnan zhah xundus.
Avatar de l’utilisateur
Arcavius
Dracoliche
Messages : 1426
Inscription : Dim 1 Avr 2012 18:56
Localisation : Oise (60)
Version de D&D préférée : AD&D2.5
Univers de D&D préféré : Royaumes Oubliés
Race : Humain
Classe : Mage
Alignement : Neutre Bon
Dieu : Addiamemnon

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar Arcavius » Lun 13 Avr 2020 09:01

Je ne pourrai pas t'être d'un grand secours, j'y connais rien à tout ça, mais merci pour l'info. Le forum passe avant les parties, donc n'hésite pas si tu as besoin de mettre à jours. On se débrouillera.

Merci.
Terres de Leyt - Eterny : Télith Orden
L'Appel des étoiles : Blint Astham
L'Épopée : Floribert Burrows
Misterious
Dragon de bronze
Messages : 15
Inscription : Jeu 27 Juil 2017 16:21
Localisation :
Version de D&D préférée : ?
Univers de D&D préféré : ?
Race : ?
Classe : ?
Alignement : ?
Dieu :

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar Misterious » Lun 13 Avr 2020 12:19

Ca fait plus d'un an que je ne suis pas venu sur se forum ^^', je passe par curiositer et je voie que tu as besoin de moi :D
J'ai DL l'extension et installer un phpBB.
Il semblerais que le problèmes vienne des REGEX je ne connais pas dutous PHPBB mais je vais esayer de te regler ca dans la journée.
Cordialement
Avatar de l’utilisateur
szass
Staff - Façonneur de Donjons
Messages : 10170
Inscription : Jeu 29 Mars 2012 15:28
Localisation : Oubliettes du Donjon
Version de D&D préférée : AD&D2
Univers de D&D préféré : Planescape
Race : Githyanki
Classe : Illusionniste
Alignement : Chaotique Neutre
Dieu : Vlaakith CLVII
Mini Feuille de perso :

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar szass » Lun 13 Avr 2020 12:23

Merci Arcavius, mais vos parties sont importantes. Pas autant que le forum dans sa globalité certes, mais c'est impensable pour moi de les amputer d'une fonctionnalité essentielle, à savoir lancer des dés. :)

Le but est de faire évoluer le DDD avec son temps sinon à force je vais me retrouver coincé à certains endroits.

Rester en 3.1.x comme aujourd'hui n'empêche pas l'utilisation du forum, et on pourrait rester indéfiniment (ou presque) avec cette version.
Certains forums tournent encore avec phpbb 3.0.x, et d'autres sont même encore en 2.x.x.

Pour la balise Dice, voici un début de piste : https://www.phpbb.com/community/viewtopic.php?t=2309881

La "question" d'Hanelyp (le développeur de la balise Dice) juste après, qui explique le fonctionnement pour 3.1.x :

Code : Tout sélectionner

uses events:
core.modify_text_for_display_before to catch text before normal bbcode processing. Matches $event['text'] against
'#\[dice\sseed=(\d+)\ssecure=(\w+):?\w*\](.+?)\[/dice\]#i'
for replacement.

core.posting_modify_message_text to inspect for a specific tag at posting time, again before bbcode processing. Matches $event['message_parser']->message against
'#\[dice\sseed=(\d+)\ssecure=(\w+):?\w*\](.+?)\[/dice\]#i'


La réponse du développeur de S9e/TextFormatter :
I looked into it but it's hard to make sense of it. The biggest problem is that you inject your PHP inside the BBCode definition rather than modify the text via an event.

If you want to modify what the user posts, you should probably do it in core.posting_modify_message_text.
For the template, don't inject PHP in second_pass_replace. How about outputting a simple <div> with your metadata as data- attributes then use events like core.modify_text_for_display_after and core.modify_format_display_text_after to fully render the div?

You could have a custom BBCodes such as this:

Code : Tout sélectionner

[dice seed={NUMBER} secure={IDENTIFIER}]{TEXT}[/dice]

Code : Tout sélectionner

<div data-seed="{NUMBER}" secure="{IDENTIFIER}">{TEXT}</div>


Then you would use the events mentionned above to add your dice roll to the HTML with preg_replace_callback() using the values in the div's attributes.




Quel bordel :ugeek:
Lolth tlu malla. Jal ultrinnan zhah xundus.
Avatar de l’utilisateur
szass
Staff - Façonneur de Donjons
Messages : 10170
Inscription : Jeu 29 Mars 2012 15:28
Localisation : Oubliettes du Donjon
Version de D&D préférée : AD&D2
Univers de D&D préféré : Planescape
Race : Githyanki
Classe : Illusionniste
Alignement : Chaotique Neutre
Dieu : Vlaakith CLVII
Mini Feuille de perso :

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar szass » Lun 13 Avr 2020 12:24

Misterious a écrit :Ca fait plus d'un an que je ne suis pas venu sur se forum ^^', je passe par curiositer et je voie que tu as besoin de moi :D
J'ai DL l'extension et installer un phpBB.
Il semblerais que le problèmes vienne des REGEX je ne connais pas dutous PHPBB mais je vais esayer de te regler ca dans la journée.
Cordialement

Oh :o
Merci de te pencher dessus Misterious, j'ai posté en même temps que toi juste au-dessus (avec un début de piste). Il semble en effet que les Regex sont en cause comme tu pourras le voir.
Si tu trouves une solution, ce serait génial :+1:
Lolth tlu malla. Jal ultrinnan zhah xundus.
Misterious
Dragon de bronze
Messages : 15
Inscription : Jeu 27 Juil 2017 16:21
Localisation :
Version de D&D préférée : ?
Univers de D&D préféré : ?
Race : ?
Classe : ?
Alignement : ?
Dieu :

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar Misterious » Lun 13 Avr 2020 12:49

Je suis dessu, pour le moment le plus compliquer est de comprendre l'api de PHPBB et surtous les changement entre les versions.
1d100 => 44 => 44
Avatar de l’utilisateur
szass
Staff - Façonneur de Donjons
Messages : 10170
Inscription : Jeu 29 Mars 2012 15:28
Localisation : Oubliettes du Donjon
Version de D&D préférée : AD&D2
Univers de D&D préféré : Planescape
Race : Githyanki
Classe : Illusionniste
Alignement : Chaotique Neutre
Dieu : Vlaakith CLVII
Mini Feuille de perso :

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar szass » Lun 13 Avr 2020 13:01

Merci :)
Phpbb 3.2 (et certainement 3.3 aussi) utilise la librairie S9e/TextFormatter (la raison pour laquelle j'ai cité le topic concerné). Je ne sais pas si tu connais cette librairie, mais c'est la raison principale qui engendre des incompatibilités entre 3.1.x et les versions suivantes.
Lolth tlu malla. Jal ultrinnan zhah xundus.
Misterious
Dragon de bronze
Messages : 15
Inscription : Jeu 27 Juil 2017 16:21
Localisation :
Version de D&D préférée : ?
Univers de D&D préféré : ?
Race : ?
Classe : ?
Alignement : ?
Dieu :

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar Misterious » Lun 13 Avr 2020 14:50

yep c'est ce que j'ai vue.
Je ne connais pas la lib et la doc est pas térible.

Je pense que dans l'états le plus simple est de re écrire un plugin, compatible avec les anciennes data de jet
Avatar de l’utilisateur
szass
Staff - Façonneur de Donjons
Messages : 10170
Inscription : Jeu 29 Mars 2012 15:28
Localisation : Oubliettes du Donjon
Version de D&D préférée : AD&D2
Univers de D&D préféré : Planescape
Race : Githyanki
Classe : Illusionniste
Alignement : Chaotique Neutre
Dieu : Vlaakith CLVII
Mini Feuille de perso :

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar szass » Lun 13 Avr 2020 14:53

Oui on peut faire comme ça aussi, c'est ce que je t'avais indiqué en MP (tu ne l'as encore lu). :)
Et même si ce n'est pas compatible avec les anciens dés lancés, ce n'est pas très grave.
Tu testes sur phpbb 3.2 ou 3.3 du coup ?
Lolth tlu malla. Jal ultrinnan zhah xundus.
Avatar de l’utilisateur
elendil
Dracoliche
Messages : 6428
Inscription : Dim 1 Avr 2012 17:45
Localisation : In the forever dark woods
Version de D&D préférée : AD&D2
Univers de D&D préféré : Greyhawk
Race : Humain
Classe : Ranger
Alignement : ?
Dieu : ?

Re: Recherche développeur php/phpbb pour mettre à jour la balise Dice

Messagepar elendil » Lun 13 Avr 2020 16:22

Je n'y connais rien. Bon courage Szass ! :D
On compte sur toi :mrgreen:
ImageImageImageImageImageImage

Revenir vers « Contributions »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités